Cisco 1604 Configuration

This document details the steps needed to be taken to configure a Cisco 1604 router for connection to MCI's InfoLink system. In all of the following steps, the router prompt will be shown in courier font and the user input will be shown in courier bold. In all examples the assumed router name will be cisco1604; it can be changed at the cisco1604(config)# prompt using the command hostname newroutername, where newroutername is replaced by the appropriate name. Also, this document assumes that the 10-base-T ethernet interface on the router has already been configured. Cisco makes it very easy to do this with the Clickstart diskette shipped with the router.

The prompt indicates the current system input mode. To use our example router name, the initial prompt upon connection to the router, either thorough the direct console connection or via telnet, and responding correctly to the Password: prompt, would be cisco1604>. In order to enter privileged mode it is necessary to use the enable command and type in the enable password at the Password: prompt.

To enter configuration mode it is necessary to type config term at the cisco1604# (privileged) prompt. The prompt will change to cisco1604(config)# at this point. Finally, once a specific interface has been specified with the interface ifname command the prompt will change to cisco1604(config-if)#. Use the exit command to move "up" a level in the heirarchy, i.e. to get from the cisco1604(config-if)# prompt to the cisco1604(config)# prompt or from the cisco1604(config)# prompt to the cisco1604# prompt.

Load IOS 11.3

Cisco IOS 11.3 is required for the EasyIP facility. If it isn't already loaded on the router as delivered, you will have to download it from the Cisco site and load it into the flash-card on the router. The steps are somewhat involved, especially as they require a full-featured TFTP server. Details can be provided on request.

Specify the ISDN Switch Type

Type the following command to configure the ISDN switch type:
cisco1604(config)#isdn switch-type switchtype
where switchtype is replaced with either basic-dms100 or basic-5ess, as appropriate. Your telecom service provider should be able to tell you to what kind of switch you are connected.

Configure the BRI Interface

Use the following commands to configure the BRI interface:
router(config)#interface bri 0
router(config-if)#no ip address
router(config-if)#encapsulation ppp
router(config-if)#dialer pool-member 1
router(config-if)#isdn spid1 aaadddddddnnnn
router(config-if)#isdn spid2 aaadddddddnnnn

NOTE: SPIDs are not required for all ISDN switches. If their use is required, you will be informed of these numbers upon ISDN line installation or shortly thereafter.

Define a Dialer Interface

In the Cisco 11.3 architecture, dialers are defined as separate interfaces. To configure a dialer interface, use the following commands:
cisco1604(config)#interface dialer 1
cisco1604(config-if)#ip address negotiated
cisco1604(config-if)#ip nat outside
cisco1604(config-if)#encapsulation ppp
cisco1604(config-if)#dialer remote-name MCI
cisco1604(config-if)#dialer string 18888515373
cisco1604(config-if)#dialer pool 1
cisco1604(config-if)#dialer-group 1
cisco1604(config-if)#ppp authentication chap
cisco1604(config-if)#ppp chap hostname username-ISDN
cisco1604(config-if)#ppp chap password password
cisco1604(config-if)#ppp multilink

The numbers in this example are consistent with the remainder of the configuration commands in this document. People familiar with Cisco router configuration are, of course, free to change list numbers. In this case the username and password are those provided by InfoLink for access to the system. Note that our example includes the -ISDN suffix. Also note that we have specified the multilink option which will permit the use of both B-channels for a connection of 128Kbps.

Define an Access List

Use the following command to generate an access list which will permit access from any device on the internal network:
cisco1604(config)#access-list 1 permit any

Define a Dialer List

The dialer list is referenced by the dialer interface, and is linked to the previously defined access-list, and is specified with the following command:
cisco1604(config)#dialer-list 1 protocol ip list 1

Define Inside NAT

Since the Cisco 1604 has an integrated 10-Base-T ethernet port, it is necessary to define the interface associate with the port to be "inside" for the purposes of Network Address Translation (NAT). This is accomplished with the following commands:
cisco1604(config)#interface en0
cisco1604(config-if)#nat inside

Define Inside NAT Mapping

Use the following command to map "inside" addresses to a single "outside" NAT address (dynamically acquired):
cisco1604(config)#ip nat inside source list 1 interface Dialer1 overload

Define Usernames and Passwords

Since any one of three servers can issue the initial Challenge Handshake Access Protocol (CHAP) challenge, all three must be defined. Use the following commands to configure the appropriate usernames and passwords:
cisco1604(config)#username ASTMAX1 password password
cisco1604(config)#username ASTMAX2 password password
cisco1604(config)#username ASTMAX3 password password
Replace password with your InfoLink password.

Define a Default Route

Now that connectivity has been defined, it is necessary to define a default route to the network through InfoLink. This is achieved through use of the following command:
cisco1604(config)#ip route 0.0.0.0 0.0.0.0 dialer 1

Save the Configuration

Issue the following command to save the configuration in non-volatile memory:
cisco1604#write mem

Verify the Configuration

Issue the following command:
cisco1604#write term

Your output should resemble the following. Note that this is just a sample, not an operational configuration; the strings of X's would be occupied by real data.

Current configuration:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname cisco1604
!
enable secret 5 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
!
username ASTMAX1 password 7 XXXXXXXXXXXXXXXXXX
username ASTMAX2 password 7 XXXXXXXXXXXXXXXXXX 
username ASTMAX3 password 7 XXXXXXXXXXXXXXXXXX 
ip subnet-zero
ip nat inside source list 1 interface Dialer1 overload
isdn switch-type basic-dms100
!
interface Ethernet0
 ip address 10.1.1.254 255.255.255.0
 ip nat inside
!
interface Serial0
 ip address 10.2.1.254 255.255.255.0
 encapsulation ppp
 clockrate 56000
!
interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn spid1 XXXXXXXXXXXXXX
 isdn spid2 XXXXXXXXXXXXXX
!
interface Dialer1
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer remote-name MCI
 dialer string 18888515373
 dialer pool 1
 dialer-group 1
 ppp authentication chap
 ppp chap hostname pselby1-ISDN
 ppp chap password 7 XXXXXXXXXXXXXXXXXX 
 ppp multilink
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
no logging buffered
access-list 1 permit any
dialer-list 1 protocol ip list 1
snmp-server community public RO
!
line con 0
line vty 0 4
 password 7 XXXXXXXXXXXXXXXXXXXX
 login
!
end

NOTES

This document does not describe the IP configuration on the "inside" of the ISDN network interface. Since all traffic flowing on the ISDN link is mapped by NAT to a single dynamically assigned external address, internal addresses lose all external significance. As long as the Cisco 1604 ethernet interface address is defined as the default route, all traffic should map correctly. For example, a PC connected to the same LAN as the router ethernet interface might have an IP address of 10.1.1.10 and should have a gateway address of 10.1.1.254 (the router.)

Copyright © 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012, 2013, 2014, 2015 by Phil Selby